华星网

通达信公式 周K线完美分享有图有副图指标

[复制链接]
4463 1

华星指标公式提示您观看的是:通达信公式 周K线完美分享有图有副图指标
要先建好第一个OCHL的公式,再建第二个周K线副图公式,发的源码是分开的两个公式. 已经装在我的软件里试用过,我用的是招商证券的通达信软件,用广发证券的也可以,另外要下载好日线数据
先建一引用指标副图,名为:OCHL
ND1970:=(YEAR-1970)*365+INTPART((YEAR-1972)/4)-IF(INTPART(YEAR/4)=YEAR/4,1,0)+DAY+(MONTH-1)*30+IF(MONTH2 AND INTPART(YEAR/4)=YEAR/4,1,IF(MONTH>2 AND NOT(INTPART(YEAR/4)=YEAR/4),2,0));
C1:C;
O1:REF(O,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1)));
H1:HHV(H,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);
L1:LLV(L,BARSLAST(ND1970-REF(ND1970,1)>WEEKDAY-REF(WEEKDAY,1))+1);
再建一指标,名为:周K线副图,源码为:
WO1:="OCHL.O1#WEEK";
WC:="OCHL.C1#WEEK";
WH:="OCHL.H1#WEEK";
WL:="OCHL.L1#WEEK";
K1:=WO1=REF(WO1,1) AND WC=REF(WC,1) AND WH=REF(WH,1) AND WL=REF(WL,1);
K3:=REF(C,1)=DYNAINFO(3) AND O=DYNAINFO(4) AND C=DYNAINFO(7) AND H=DYNAINFO(5) AND L=DYNAINFO(6);
DD:=REF(BARSLAST(K1=0)+1,1),LINETHICK0;
DD1:=CROSS(BACKSET((K1=0 OR K3) AND DD=5,4),0.5),NODRAW;
DD2:=CROSS(BACKSET((K1=0 OR K3) AND (DD=4 OR DD=3),3),0.5),NODRAW;
DD3:=CROSS(BACKSET((K1=0 OR K3) AND DDWO OR (WC=WO AND WC>REF(WC,BARSLAST(K1=0)+1));
STICKLINE(K0 AND BK1,WH,WC,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND BK1,WO,WL,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND K1=0,WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND (BK2 OR K3),WC,WO,0,0),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORLIMAGENTA;
STICKLINE(K0 AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORLIMAGENTA;
STICKLINE(NOT(K0) AND BK1,WH,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND BK1,WC,WL,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND K1=0,WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND (BK2 OR K3),WC,WO,0,0),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WC,WC,8,1),COLORCYAN;
STICKLINE(NOT(K0) AND ((K1 AND BK2=0 AND K3=0) OR BK3),WO,WO,8,1),COLORCYAN;
MA1:MA(C,20),COLORWHITE;
MA2:MA(C,60),COLORYELLOW;
MA3:MA(C,120),COLORMAGENTA;

222038n5by4wux4lw33b34.png

222038n5by4wux4lw33b34.png

分享至:
| 0 人收藏
回复

举报 使用道具

1 个评论

菜头 发表于 7-23 11:04:13  | 显示全部楼层
很精彩,深受启发,今后在盘中慢慢领会与实践,谢谢提供分享!
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:鲁ICP备20004641号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表