华星网

公式 重新整合的骑黑马配图副图指标

[复制链接]
6110 1

华星指标公式提示您观看的是:公式 重新整合的骑黑马配图副图指标
整合的前辈老师的指标,用法简洁明了,短中线可见,强弱区可观察下方颜色变化,源码如下:
STICKLINE(0.01,105,0,5,0)COLOR003300;
STICKLINE(0.01,-10,0,5,0)COLOR003300;
{INPUT:GU1(6,1,100),GU2(27,1,200),GU3(5,1,100),N1(9,1,90),M1(3,30,1);}
MA5:=EMA(C,5);
MA13:=EMA(C,13);
UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),0),COLOR0000FF;
DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
(MA13,MA5))+1),0),COLOR00FF00;
STICKLINE(UP,-10,-1,4,0),COLOR0000BB;
STICKLINE(DOWN,-10,-1,4,0),COLOR009900;
LX_JW1:=100*(CLOSE-REF(CLOSE,GU1))/REF(CLOSE,GU1);
LX_JW2:=MA(LX_JW1,(2*GU1))*2.5;
LX_JW3:=(CLOSE-LLV(LOW,GU2))/(HHV(HIGH,GU2)-LLV(LOW,GU2))*100;
LX_JW4:=3*SMA(LX_JW3,5,1)-2*SMA(SMA(LX_JW3,5,1),3,1);
LX_JW5:=EMA(LX_JW4,GU3);
LX_JW6:=REF(LX_JW5,1);
DRAWBAND(LX_JW2+50,RGB(200,0,210),50,RGB(60,180,50));
A1:=3*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2)-2*SMA((C-LLV(L,55))/(HHV(H,55)-LLV(L,55))*100,5,2);
黑马线:EMA(A1,5),LINETHICK3,COLORRED;
反切线:90-EMA(A1,5),LINETHICK3,COLOR00AAFF;
A2:=(黑马线-REF(黑马线,1))/REF(黑马线,1)*100;
A3:=EMA(C,5);
A4:=((C-LLV(L,21))/(HHV(H,21)-LLV(L,21)))*100;
趋势线: (EMA(4*SMA(A4,6,1)-3*SMA(SMA(A4,5,1),5,1),2)),LINETHICK1,COLORYELLOW,NODRAW;
A5:=(HHV(H,60)-C)/(HHV(H,60)-LLV(L,60))*100;
DRAWTEXT(FILTER(REF(黑马线,1)>90 AND A220 AND 黑马线REF(A2,1))*25,COLORRED;
机会来临:REF(IF((MA(C,5)-C)/C>0.04 AND (MA(C,10)-MA(C,5))/MA(C,5)>0.04,30,0),1),LINETHICK2,COLORF830F8;
大势已去:IF(CROSS(黑马线,A1) AND 黑马线>70 AND 趋势线>80,90,100),LINETHICK2,COLORGREEN;
50,LINETHICK3,COLORE66878,POINTDOT;
70,COLORYELLOW,POINTDOT,LINETHICK2;
DRAWTEXT(CROSS(黑马线,反切线),黑马线,'上涨'),COLORWHITE;
DRAWTEXT(CROSS(黑马线,70),黑马线,'快牛'),COLORYELLOW;
VAR1:=1;
VAR2:=((((2*CLOSE)+HIGH)+LOW) / 4);
高位:90,COLORFFFF00;
低位:20,COLORMAGENTA;
VAR4:=LLV(LOW,5);
VAR5:=HHV(HIGH,4);
C1:(EMA((((VAR2-VAR4)/(VAR5-VAR4))*100),4)*VAR1),COLORRED;
C2:(EMA(((0.667*REF(C1,1))+(0.333*C1)),2)*VAR1),COLORWHITE;
DRAWICON(CROSS(C1,C2) AND C2>0,C2,1);
DRAWICON(CROSS(C2,C1) AND C2-100,C1,2);
条件:=CROSS(C1,C2) AND C190;
TJ1:=CROSS(C1,C2);
TJ2:=CROSS(C2,C1);
TJ3:=CROSS(C1,C2) AND REF(C1,1)80;
DRAWTEXT(条件,20,'买'),COLORWHITE;
DRAWTEXT(条件0,85,'卖'),COLORYELLOW;
DRAWTEXT(CROSS(C1,75),70,'冲顶'),COLORWHITE;

222241apzppzuo44goo8hu.png

222241apzppzuo44goo8hu.png

分享至:
| 0 人收藏
回复

举报 使用道具

1 个评论

成全塔 发表于 7-22 17:09:08  | 显示全部楼层
美女妹妹晚上好!
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:鲁ICP备20004641号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表