华星网

公式 密码决策系统主副图指标

[复制链接]
4443 1

华星指标公式提示您观看的是:公式 密码决策系统主副图指标
{买卖密码}
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RD:=(CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE0,V/CAPITAL*100,V),NODRAW;
收:=FINANCE(33),NODRAW;
流:FINANCE(7)/100000000,NODRAW;
TT:=IF(ISLASTBAR,240/FROMOPEN,1);
NN:=120;
HH:=HHV(V*TT,NN);
LL:=LLV(V,NN);
最高:=CONST(HH);
最低:=CONST(LL);
RCC:=最高*0.9-(最高-最低)*0.5;
RHL:=RCC;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
P:=最高/120;
{顶底摸块}
神:=2*SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1)-(3*HHV(SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1),2)-2*SMA(V*((C+L)/2+(H+C)/2+L)/3,2,1)/SMA(V,2,1));
奇:=(2*神+EMA((2*(C+L)/2+(H+C)/2+L+O)/5,2)+2*((EMA((C*2+H+L+O)/5,5)+MA((C*2+H+L+O)/5,13)+MA((C*2+H+L+O)/5,21))/3)+((EMA
((C*2+H+L+O)/5,13)+MA((C*2+H+L+O)/5,21)+MA((C*2+H+L+O)/5,34))/3)+((EMA((C*2+H+L+O)/5,21)+MA((C*2+H+L+O)/5,34)+MA((C*2+H+L+O)/5,55))/3))/7;
分清:=(FORCAST(HHV((C+L)/2,1),21)+(EMA(((C+L)/2+L+(H+C)/2)/3,55)-(C-EMA(((C+L)/2+L+(H+C)/2)/3,55))))/2;
放心买入:=(((C+L)/2+(H+C)/2+L)/3+(3*(C+H+L+(O+C+L)/3)/4-2*(C+L)/2))/2;
强:=(EMA((分清+3*((EMA(放心买入,5)*5+分清)/6+((EMA(奇,5)+EMA(奇,8)+EMA(奇,13))/3))/2)/4,3)/3),POINTDOT,COLOR00FFFF;
验证:=((((C+L)/2-LLV(L,24))/(HHV((H+C)/2,24)-LLV(L,24))*1.1*(C+L)/2));
续持验证:=EMA((2*(5*((EMA((2*C+L)/3,2)-EMA((2*C+H)/3,5))
-EMA((EMA((2*C+L)/3,2)-EMA((2*C+H)/3,5)),21)))
+(((C*2+H)/3+(C*2+H)/3)/2)+EMA(验证,2))/4,2),COLOR555555;
AR:=(2*(C+L)/2+REF((C+L)/2,1))/3;
BR:=(7*(C+L)/2+6*REF((C+L)/2,1)+5*REF((C+L)/2,2)
+4*REF((C+L)/2,3)+3*REF((C+L)/2,4)
+2*REF((C+L)/2,5)+REF((C+L)/2,6))/28;
VARA2:=LLV(MA(LOW,3),3);
VARA3:=HHV(MA(HIGH,3),3);
比:=TT;
昨V:=REF(V,1);
T:=IF(ISLASTBAR,IF(FROMOPEN>60,IF(FROMOPEN-INTPART(FROMOPEN/60)*60=0,1,
60/(FROMOPEN-INTPART(FROMOPEN/60)*60)),60/FROMOPEN),1);
WJ:=(H+L+C)/3;
V1:=IF(H=L,1,H-MAX(O,C));
V2:=IF(H=L,1,MAX(C,O)-WJ);
V3:=IF(H=L,1,MIN(O,C)-L);
V4:=IF(H=L,1,WJ-MIN(C,O));
V5:=VOL/IF(H=L,4,H-L);
V6:=(V1*V5);
V7:=(V2*V5);
V8:=(V3*V5);
V9:=(V4*V5);
买盘1:=DYNAINFO(23)*比;
卖盘1:=DYNAINFO(22)*比;
买盘2:=IF(ISLASTBAR AND C>300,(V9+V8)*TT,(V9+V8));
卖盘2:=IF(ISLASTBAR AND C>300,(V6+V7)*TT,(V6+V7));
买盘:=IF(ISLASTBAR AND PERIOD=5 AND C=O,0,买盘+卖盘,2.8,1),COLORRED;
STICKLINE(C=0,0,买盘,2.5,0),COLORRED;
STICKLINE(买卖差>=0 AND C>=MA(C,30),0,买盘,3.0,0),COLORRED;
STICKLINE(买卖差>=0,0,卖盘,1.1,0),COLOR998800;
STICKLINE(买卖差>=0 AND C>=MA(C,30),0,卖盘,1.5,0),COLORDDCC00;
STICKLINE(买卖差=MA(C,30),0,买盘,3.0,0),COLORRED;
STICKLINE(买卖差=MA(C,30),0,卖盘,1.5,0),COLORDDCC00;
A1:=REF(CLOSE,1);
B1:=(买盘+卖盘)V AND V>B1;
STICKLINE(B1,0,卖盘,2,0),COLORYELLOW;
((80-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
((50-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
((20-HLMN3)*HLMN2/HLMN4+HLMN1),COLORCCCCCC,LINETHICK1,DOTLINE;
KA:=(EMA((CLOSE-VARA2)/(VARA3-VARA2)*100,4)-50)*0.5+50;
DB:=EMA(0.667*REF(KA,1)+0.333*KA,2);
JJ:=3*KA-2*DB;
((KA-HLMN3)*HLMN2/HLMN4+HLMN1),COLORFFF111,LINETHICK1;
((DB-HLMN3)*HLMN2/HLMN4+HLMN1),COLOR00FF00,LINETHICK1;
((JJ-HLMN3)*HLMN2/HLMN4+HLMN1),COLORFF00FF,LINETHICK1;
IF(续持验证=强,-5*P,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;
IF(续持验证>= REF(续持验证,1),-10*P,DRAWNULL),CIRCLEDOT,COLORRED,LINETHICK1;
IF(续持验证密码3,HLMAX,HLMAX*0.96,3,0),COLORRED;
STICKLINE(1,HLMAX*0.98,HLMAX*0.98,3,0),COLORWHITE;
STICKLINE(1,HLMAX*0.93,HLMAX*0.89,3,0),COLORRED;
绿灯卖:STICKLINE(密码2(密码3) AND C>密码2 OR 密码2>密码4,HLMAX*0.82,HLMAX*0.86,3,0),COLORRED;
操作段2:STICKLINE(C>密码2 AND 密码1>密码3,HLMAX*0.82,HLMAX*0.86,3,0),COLORMAGENTA;
操作段3:STICKLINE(密码1密码4,HLMAX*0.82,HLMAX*0.86,3,0),COLORYELLOW;
STICKLINE(密码1>(密码3) AND C>密码2 OR 密码2>密码4 OR C>密码2 AND 密码1>密码3,HLMAX*0.84,HLMAX*0.84,3,0),COLORWHITE;
{两用主图 ★分时_日线两用主图★}
{P= 0 , 2 , 1}
NN:=250;
最高:=CONST(HHV(H,NN));
最低:=CONST(LLV(L,NN));
RCC2:=最高*0.9-(最高-最低);
RCC1:=最高-(最高-最低)/2;
RHL:=RCC2;
HLMAX:=最高;
HLMIN:=最低;
HLMN1:=(HLMAX+HLMIN)/2;
HLMN2:=HLMAX-HLMIN;
HLMN3:=(100-0)/2*1.3;
HLMN4:=(100-0)/1*1.3;
{时间设置}
CC:=CLOSE,COLORWHITE,LINETHICK2;
VAR7:=SMA(CC,6.18,1);
VAR8:=SMA(VAR7,3.14,1);
BB:=ATAN(VAR7-REF(VAR7,1))*3.1416*10,NODRAW,COLORWHITE;
EE:=ATAN(VAR8-REF(VAR8,1))*3.1416*10,NODRAW,COLORWHITE;
【立度】:BB+EE,NODRAW,COLORYELLOW;
{强弱界}
MMA30:=EMA(CLOSE,30);
强弱界定:=IF(PERIOD=0,EMA(CLOSE,900),DRAWNULL);
DRAWBAND(MMA30,RGB(100,0,0),强弱界定,RGB(95,120,115));
RCC:=IF(PERIOD=0 ,DYNAINFO(3),DYNAINFO(3)*0.98);
S2:=SMA(C,3,1);
S6:=SMA(C,5,1);
DK:=4*(S2-S6);
KK:=1;
{分时MACD}
昨收:=RCC;
HH:=DYNAINFO(5);
LL:=DYNAINFO(6);
FK:=MAX(HH-昨收,昨收-LL)*0.1;
ZS:=昨收-FK*3.2;
Q1:=昨收-FK*3.22;
Q2:=昨收-2*FK*3.22;
Q3:=昨收-3*FK*3.2;
DIF:=(EMA(CLOSE,13) - EMA(CLOSE,24));
DEA:=(EMA(DIF,6));
MACD:=5*(DIF-DEA);
STICKLINE(MACD>=0 AND MACD>=REF(MACD,1),RCC*1,MACD*3+RCC*1,4,0),COLOR992299,LINETHICK3;
STICKLINE(MACD>=0 AND MACD=REF(MACD,1),RCC*1,MACD*3+RCC*1,4,0),COLOR064499,LINETHICK3;
STICKLINE(MACD0,RCC*KK,RCC*KK+DK,1,1),COLOR00AAAA;
STICKLINE(DK20,H,2);
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RD:=(CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=B2 OR B1>=B3)) OR ((B1=CMAX AND (B2=CMIN OR B3=CMIN)) AND CLOSE>=B2) OR
(B2=CMAX AND B3=CMIN AND CLOSE>=B1) OR (B3=CMAX AND CLOSE>=B1 AND CLOSE>=B2);
变盘:=CLOSE=CMAX AND B1=CMIN;
下跌:=(CLOSE=CMIN AND (B1[B]=B2) OR ((B2=CMIN AND B1B2) AND B2>=B4 AND CLOSE[B]=O,L,H,0,1),COLORRED;
STICKLINE(PERIOD!=0 AND C0,O,C,0,0),COLORFFFFFF;
DRAWTEXT_FIX(P=0 AND PERIOD!=0 ,0,0.06,0,'黄持股、绿持币、 K线上强多留意、黄带立度送你金。'),COLORYELLOW;
下档线:=(((CLOSE - LLV(LOW,13)) / (HHV(HIGH,13) - LLV(LOW,13))) * 100);
RRRSV:=SMA(下档线,3,1);
KKK:=SMA(RRRSV,3,1);
DDD1:=((3 * RRRSV) - (2 * KKK));
JJ12:=(((CLOSE - LLV(LOW,55)) / (HHV(HIGH,55) - LLV(LOW,55))) * 100);
RSV24:=SMA(JJ12,3,1);
K24:=SMA(RSV24,3,1);
D24:=((3 * RSV24) - (2 * K24));
压力:=IF(CROSS(D24,DDD1),HIGH,REF(HIGH,BARSLAST(CROSS(D24,DDD1)))),COLORFFFFFF;
决策:=IF(ISLASTBAR,压力,DRAWNULL),COLORMAGENTA;
STICKLINE(ISLASTBAR ,决策,决策,60,1),LINETHICK3,COLORMAGENTA;
底部:=LLV(HIGH,30),COLOR00FF00;
超跌:=IF(ISLASTBAR,底部,DRAWNULL),COLORWHITE;
STICKLINE(ISLASTBAR ,超跌,超跌,60,1),LINETHICK3,COLORWHITE;
STICKLINE(ISLASTBAR AND (红持股 OR REF(红持股,1)=1),今离场价,今离场价,35,1),COLOR0000FF;
STICKLINE(ISLASTBAR AND (阴观望 OR REF(阴观望,1)=1),今进场价,今进场价,35,1),COLOR00FF00;
IF(PERIOD=0 ,C,DRAWNULL)LINETHICK1,COLORCCCCCC;
分时均价线:IF(PERIOD=0 ,SUM(C*V,240)/SUM(V,240),DRAWNULL),COLORYELLOW;
IF(PERIOD!=0,EMA((O+H+L)/3,4)+((H+L)/2-REF((O+H+L)/3,3))/4,DRAWNULL)COLORGREEN;
K1:=IF(PERIOD=0 ,"分时引.密码3#DAY",DRAWNULL);
D1:=IF(PERIOD=0 ,"分时引.密码1#DAY",DRAWNULL);
F1:=IF(PERIOD=0 ,"分时引.密码4#DAY",DRAWNULL);
J1:=IF(PERIOD=0 ,"分时引.密码2#DAY",DRAWNULL);
J1,COLORYELLOW,LINETHICK1;
D2:D1+(昨收-K1),DOTLINE,COLORWHITE,LINETHICK1;
J2:J1+(昨收-F1),COLORWHITE,LINETHICK1;
所属地域:DRAWTEXT_FIX(ISLASTBAR ,0.08,0.01,1,DYBLOCK),COLORYELLOW;
所属行业:DRAWTEXT_FIX(ISLASTBAR ,0.1,0.01,0,HYBLOCK),COLORYELLOW;

分享至:
| 0 人收藏
回复

举报 使用道具

1 个评论

艾可老师 发表于 7-22 12:41:45  来自手机  | 显示全部楼层
太好了,认真学习了。
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:鲁ICP备20004641号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表