华星网

公式 趋势变色优化主图指标

[复制链接]
4529 2

华星指标公式提示您观看的是:公式 趋势变色优化主图指标
趋势变色【主图 源码 附图】优化 ( 限时贴)
{n :1 ,100 ,9}
NN:=100;
高点:=CONST(HHV(H,NN)),NODRAW;
低点:=CONST(LLV(L,NN)),NODRAW;
JRH:=HHV(C,2);
JRL:=LLV(C,2);
MA3:=MA(CLOSE,3);
YTSL:=(3*CLOSE+LOW+OPEN+HIGH)/6;
R1:=(CLOSE>REF(CLOSE,1) AND CLOSE>REF(CLOSE,2));
R2:=(REF(R1,1) AND CLOSE=REF(CLOSE,2));
R3:=(REF(R2,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R5:=(REF(R4,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R7:=(REF(R6,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R9:=(REF(R8,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RB:=(REF(RA,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
RD:=(CLOSE=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R10:=(REF(RF,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R12:=(REF(R11,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R14:=(REF(R13,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R16:=(REF(R15,1) AND CLOSE>=REF(CLOSE,1) AND CLOSE=REF(CLOSE,2));
R18:=(REF(R17,1) AND CLOSE>=REF(CLOSE,1) AND CLOSEREF(個,1),2);
往:IF(K6,個,DRAWNULL),COLOR0000AA,LINETHICK1;
K7:=BACKSET(十>REF(十,1),2);
来:IF(K7,十,DRAWNULL),COLOR0000BB,LINETHICK1;
K8:=BACKSET(百>REF(百,1),2);
无:IF(K8,百,DRAWNULL),COLOR0000CC,LINETHICK1;
K9:=BACKSET(千>REF(千,1),2);
白:IF(K9,千,DRAWNULL),COLOR0000DD,LINETHICK1;
K10:=BACKSET(万>REF(万,1),2);
丁:IF(K10,万,DRAWNULL),COLOR0000EE,LINETHICK1;
個Z:=EMA(玄悟斋主,3) ;
十Z:=EMA(玄悟斋主,5);
百Z:=EMA(玄悟斋主,7);
千Z:=EMA(玄悟斋主,9);
万Z:=EMA(玄悟斋主,11);
B1:=BACKSET(個ZREF(個Z,1),2);
道:IF(B6,個Z,DRAWNULL),COLORF67ACD,LINETHICK1;
B7:=BACKSET(十Z>REF(十Z,1),2);
心:IF(B7,十Z,DRAWNULL),COLORF68ACD,LINETHICK1;
B8:=BACKSET(百Z>REF(百Z,1),2);
静:IF(B8,百Z,DRAWNULL),COLORF69ACD,LINETHICK1;
B9:=BACKSET(千Z>REF(千Z,1),2);
中:IF(B9,千Z,DRAWNULL),COLORF70ACD,LINETHICK1;
B10:=BACKSET(万Z>REF(万Z,1),2);
参:IF(B10,万Z,DRAWNULL),COLORF71ACD,LINETHICK1;
BIAS0:= (C-MA(C,2))/MA(C,2)*100;
HXL:=V/CAPITAL*100;
D1:=INDEXC;
D2:=MA(D1,13);
DR2:=D2>1.050*D1;
E1:=(C-HHV(C,12))/HHV(C,12)*10;
E2:=(C-REF(C,26))/REF(C,26)*10;
E3:=MA(C,3);
SJ1:=DR2;
SJ2:=E2 REF(HHZ,1)));
LL1:=BARSLAST((LLZLL1),CLOSE,OPEN,2,0),COLORGREEN;
STICKLINE((HH1 > LL1),HIGH,LOW,0,0),COLORGREEN;
STICKLINE((HH1 =裁决 AND BETWEEN(裁决,C,O),1,0);
CO:=(C-O);
STICKLINE(VAR4X,O,O+CO/3,3.6,0),COLORLIMAGENTA;
STICKLINE(VAR1X,O,O+CO/3,3.6,0),COLORGREEN;
MA10:=MA(C,10),COLORGREEN,LINETHICK2;
MA20:=MA(C,20),COLORCYAN,LINETHICK2;
MA30:=MA(C,30),COLORYELLOW,LINETHICK2;
{MA60:=MA(C,60),COLORMAGENTA,LINETHICK2;
MA120:=MA(C,120),COLORRED,LINETHICK3;}
VAR1:=(C- LLV(L,32)) / (HHV(H,32) - LLV(L,32)) * 1.2 * C;
VAR2:=EMA(VAR1,3);
VAR3Z:=EMA(VAR1,5);
VAR4Z:=EMA(VAR1,7);
VARA:=VAR3Z >= VAR4Z AND VAR2REF(VAR2,1);
超短:=MA(VAR2,6);
短线:=MA(超短,2);
STICKLINE(FILTER(VARB,3),L*0.985,L*0.995,2,0),COLORFF00FF;
STICKLINE(CROSS(短线,超短),L*1.035,L*1.05,3,0),COLORBLUE;
{STICKLINE(CROSS(短线,超短) AND COUNT(CROSS(短线,超短),10)=2,L*1.045,L*1.06,3,1),COLORGREEN;}
DRAWTEXT(CROSS(短线,超短) AND COUNT(CROSS(短线,超短),10)=2,L*1.064,'跑'),COLORGREEN;
DRAWTEXT(FILTER(VARB,3),L*0.98,'醒醒'),COLORFF00FF;
DRAWTEXT(CROSS(短线,超短),L*1.054,'睡觉'),COLORWHITE;
AAZ:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,1)=REF(CLOSE,5)),IF(REF(CLOSE,5)REF(CLOSE,3) AND IF(REF(CLOSE,3)>REF(CLOSE,4),1,IF(REF(CLOSE,4)>REF(CLOSE,5),REF(CLOSE,1)>REF(CLOSE,4) OR (REF(CLOSE,2)>REF(CLOSE,4) AND REF(CLOSE,3)REF(CLOSE,6),1,REF(CLOSE,6)>REF(CLOSE,7))));
DRAWTEXT(AAZ AND CLOSE>REF(OPEN,2),LOW*0.97,'三平底'),COLORWHITE;
DRAWTEXT(BBZ AND CLOSE<REF(CLOSE,2),HIGH*1.02,'三平顶'),COLORCYAN;
DRAWTEXT(CURRBARSCOUNT=20,L*1.2,'★趋势第一背景提示:绿买,粉持,紫跌,橙灰逃,供参考!'),COLOR00FFFF;

222438nvq3fquhuxnhu2dv.jpg

222438nvq3fquhuxnhu2dv.jpg

分享至:
| 0 人收藏
回复

举报 使用道具

2 个评论

独孤星飞 发表于 7-22 12:24:57  | 显示全部楼层
真的是点点滴滴的精华 谢谢老师的分享
回复

举报 使用道具

股市苍老师 发表于 8-2 09:54:47  | 显示全部楼层
谢谢楼主的分享,你辛苦了!!!
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:鲁ICP备20004641号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表