华星网

公式 基本面操盘秘诀-财务优化-财务报表分折选股选股解释主图指标

[复制链接]
5131 1

华星指标公式提示您观看的是:公式 基本面操盘秘诀-财务优化-财务报表分折选股选股解释主图指标
为感谢朋友们的支持与厚爱,也应几位留言朋友的要求,对通达信财务K线主图进行了优化,并配上财务基本面选股公式。本人测试了三款通达信软件都能通过,本组合对中初级投资者应有较大帮助,当然,在高手面前是班门弄斧了!
本组合引用的专业财务数据使用很方便,抛砖引玉希望大家多交流,欢迎优化。也希望得到老师和广大朋友的支持交流。别忘了上点果果,给点动力哦!!!
提示:使用前请保证财务数据的及时下载。
财务K线主图源码:(优化)
{均线}
MA5:MA(CLOSE,5);
MA10:MA(CLOSE,10);
MA20:MA(CLOSE,20);
MA60:MA(CLOSE,60);
MA120:MA(CLOSE,120),COLORFF972F;
金叉:=CROSS(MA5,MA10);
DRAWTEXT(金叉,MA10*0.99,'←金叉买'),COLORYELLOW;
二金叉:=CROSS(MA10,MA20);
DRAWTEXT(二金叉,MA20*0.98,'←二金叉加仓'),COLOR1880FF;
{无穷}
无穷:DMA(CLOSE,(VOL)/(CAPITAL));
XG:=CROSS(C,无穷) AND V>REF(V,1)*1.618;
STICKLINE(C/REF(C,1)>1.095,C,O,2,0),COLORMAGENTA;
STICKLINE(C/REF(C,1)D AND CREF(D,1),H*1.02,'←卖'),COLORYELLOW;
DRAWTEXT(REF(C,1)D AND DREF(C,1)*1.045,L*0.98, '←买'),COLORMAGENTA;
HH:=CONST(HHV(H,160));
LL:=CONST(LLV(L,160));{160可改成你习惯锁定的日K线数}
HL1:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.76,0.04));
HL2:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.80,0.08));
HL3:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.84,0.12));
HL4:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.88,0.16));
HL5:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.92,0.20));
HL6:=CONST(IF(CONST(REF(MA(C,10),10))>CONST((HH+LL)/2),0.96,0.24));
DRAWTEXT_FIX(1,0.00,0,0,'所属行业:')COLOR0080FF;
DRAWTEXT_FIX(1,0.07,0,0,HYBLOCK)COLOR0080FF;
DRAWTEXT_FIX(1,0.14,0,0,'所属地区:')COLOR00FFFF;
DRAWTEXT_FIX(1,0.21,0,0,DYBLOCK)COLOR00FFFF;
DRAWTEXT_FIX(1,0.00,0.06,0,'主题投资:')COLOR0000FF;
DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
DRAWTEXT_FIX(1,0.00,0.12,0,'财务分折:')COLORMAGENTA;
DRAWTEXT_FIX(1,0.07,0.06,0,EXTERNSTR(0,1))COLOR0000FF;
{股本市值}
总股本:=STRCAT(STRCAT('总股本: ',CON2STR(TOTALCAPITAL/1000000,2)),'亿');
流通盘:=STRCAT(STRCAT(' 流通盘: ',CON2STR(CAPITAL/1000000,2)),'亿');
全流通:=STRCAT(' 全流通: ',CON2STR((CAPITAL/1000000)/(TOTALCAPITAL/1000000),2));
市值:=STRCAT(STRCAT(' 流通市值: ',CON2STR((CAPITAL/1000000)*C,2)),'亿');
上市天数:=STRCAT(' 上市天数: ',CON2STR(FINANCE(42),0));
{上市日期:=STRCAT(' 上市日期: ',CON2STR(HHV((BARSCOUNT(C)=0)*(DATE+19000000),0),0));}
股本市值:=STRCAT('股本市值: ',STRCAT(STRCAT(STRCAT(STRCAT(总股本,流通盘),全流通),市值),上市天数));
{业绩综合}
市盈率:=STRCAT('市盈率: ',CON2STR(C/FINANCE(33),2));
市销率:=STRCAT(' 市销率: ',CON2STR(C/(FINANCE(20)/FINANCE(1)),2));
市净率:=STRCAT(' 市净率: ',CON2STR(C/FINANCE(34),2));
净资收益率:=STRCAT(' 净资收益率: ',CON2STR(FINANCE(33)/FINANCE(34)*100,2));
毛利率:=STRCAT(' 毛利率: ',CON2STR((FINANCE(20)-FINANCE(21))/FINANCE(20)*100,2));
净利润率:=STRCAT(' 净利润率 ',CON2STR(FINANCE(30)/FINANCE(20)*100,2));
主营利润率:=STRCAT(' 主营利润率 ',CON2STR(FINANCE(23)/FINANCE(20)*100,2));
当前业绩:=STRCAT('当前业绩: ',STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(STRCAT(市盈率,市销率),市净率),净资收益率),毛利率),净利润率),主营利润率));
{风险系数}
X1:=(FINANCE(11)-FINANCE(15))/FINANCE(10)*1.2;
X2:=(FINANCE(31)+FINANCE(17))/FINANCE(10)*1.4;{盈余公积用资本公积金代替};
X3:=FINANCE(23)/FINANCE(10)*3.3;
X4:=FINANCE(19)/FINANCE(15)*0.6;{缺长期负债或负债总额}
X5:=FINANCE(20)/FINANCE(15)*0.999;
Z值:=X1+X2+X3+X4+X5;
预警:=IF(Z值=1.2 AND Z值1.50,10,IF(市盈率20,9,
IF(市盈率40,8,IF(市盈率60,7,
IF(市盈率80,6,IF(市盈率100,5,
IF(市盈率130,4,IF(市盈率160,3,
IF(市盈率190,2,IF(市盈率220,1,0))))))))));
市净率评分:=IF(市净率>1,10,IF(市净率0.9,9,
IF(市净率0.8,8,IF(市净率0.7,7,
IF(市净率0.6,6,IF(市净率0.5,5,
IF(市净率0.4,4,IF(市净率0.3,3,
IF(市净率0.2,2,IF(市净率0,1,0))))))))));
每股收益评分:=IF(每股收益>2.7,10,IF(每股收益2.4,9,
IF(每股收益2.1,8,IF(每股收益1.8,7,
IF(每股收益1.5,6,IF(每股收益1.2,5,
IF(每股收益0.9,4,IF(每股收益0.6,3,
IF(每股收益0.3,2,IF(每股收益0,1,0))))))))));
资产报酬率评分:=IF(资产报酬率>27,10,IF(资产报酬率24,9,
IF(资产报酬率21,8,IF(资产报酬率18,7,
IF(资产报酬率15,6,IF(资产报酬率12,5,
IF(资产报酬率9,4,IF(资产报酬率6,3,
IF(资产报酬率3,2,IF(资产报酬率0,1,0))))))))));
股本报酬率评分:=IF(股本报酬率>135,10,IF(股本报酬率120,9,
IF(股本报酬率105,8,IF(股本报酬率90,7,
IF(股本报酬率75,6,IF(股本报酬率60,5,
IF(股本报酬率45,4,IF(股本报酬率30,3,
IF(股本报酬率15,2,IF(股本报酬率0,1,0))))))))));
净值报酬率评分:=IF(净值报酬率>100,10,IF(净值报酬率80,9,
IF(净值报酬率70,8,IF(净值报酬率60,7,
IF(净值报酬率50,6,IF(净值报酬率40,5,
IF(净值报酬率30,4,IF(净值报酬率20,3,
IF(净值报酬率10,2,IF(净值报酬率0,1,0))))))))));
营业纯益率评分:=IF(营业纯益率>60,10,IF(营业纯益率50,9,
IF(营业纯益率40,8,IF(营业纯益率30,7,
IF(营业纯益率20,6,IF(营业纯益率15,5,
IF(营业纯益率10,4,IF(营业纯益率5,3,
IF(营业纯益率3,2,IF(营业纯益率0,1,0))))))))));
主营利润率评分:=IF(主营业务利润率>60,10,IF(主营业务利润率50,9,
IF(主营业务利润率45,8,IF(主营业务利润率40,7,
IF(主营业务利润率35,6,IF(主营业务利润率30,5,
IF(主营业务利润率25,4,IF(主营业务利润率20,3,
IF(主营业务利润率10,2,IF(主营业务利润率0,1,0))))))))));
负债比率评分:=IF(负债比率0 AND 负债比率10 AND 负债比率20 AND 负债比率30 AND 负债比率40 AND 负债比率50 AND 负债比率60 AND 负债比率70 AND 负债比率80 AND 负债比率80,5,IF(存货周转率60,4,
IF(存货周转率40,3,IF(存货周转率20,2,
IF(存货周转率0,1,0)))));
资产周转率评分:=IF(固定资产周转率>20,5,IF(固定资产周转率15,4,
IF(固定资产周转率10,3,IF(固定资产周转率5,2,
IF(固定资产周转率0,1,0)))));
财务优势:(市盈率评分+市净率评分+每股收益评分)+(资产报酬率评分+股本报酬率评分+
净值报酬率评分+营业纯益率评分+主营利润率评分)+负债比率评分+存货周转率评分+
资产周转率评分,COLOR0000FF;
公式解释:
1、股东权益报酬率即净资产收益率,越高代表盈利能力越强。本人将财务良好设为8,优秀设为10。太低了说明公司资产质量很一般。此外,指标太高,也找不出几家优秀公司了,故有些指标降一降吧,有些公司还是有潜力的。
2、每股净资产:财务良好设为1.5,财务优秀设为2。每股净资产是公司历年发展逐步积累而成,1.5以下表明公司历年积累不理想。财务优秀设为2主要考虑优秀企业送股和转增以后净资产不会太高。没必要设为更高。
3、每股未分配利润:财务良好设为0.3,优秀设为0.5,太低说明公司盈利能力不好,太高没必要,好公司分配完后,未分配利润不会太高,当然不会把利润分干净,设0.5为好。
4、主营收入占比:太低说明公司不务正业,
5、每股经营现金流:表明公司收到的现金,经营现金流大于利润说明公司回款良好,甚至又预收款,股价与现金流比相当于市盈率概念,但更真实,故设在0和60之间。
注:
1、本公式在选择财务指标时主要用经营现金流而不是现金流,主要是企业分红或其它因素,现金流可以为负。
2、如果副图显示财务良好或财务优秀为1,则公司财务良好或财务优秀成立,否则显示0或-。
3、在条件选股时将财务良好设为1,可选出符合条件的股票。条件即使很宽,也不到400家。同理可选财务优秀,也不过300家。公式之所以没有加流动比率、速动比率,主要考虑上市公司偿债因素不是特别重要,因它可以融资,另外,财务指标太多,选不出几家公司了,没法买股票了。
4、财务选股适合中长期投资者选股,同时对短线投机者也是重要参考指标。

222507ej2sjvj15v5ecys3.jpg

222507ej2sjvj15v5ecys3.jpg

分享至:
| 0 人收藏
回复

举报 使用道具

1 个评论

股市实相 发表于 7-22 11:00:15  | 显示全部楼层
快乐也来了。多吹牛呀。
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:鲁ICP备20004641号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表