华星网

公式 CCI优化原飞狐公式副图指标

[复制链接]
4635 3

华星指标公式提示您观看的是:公式 CCI优化原飞狐公式副图指标
用法你研究研究就明白了。当然如果你发现新的用法,请与我们分享。
STICKLINE(C,320,-320,5,0),COLOR80A16F;
M:=14;Q:=6;N:=20;
MM:=IF(PERIOD=1,M,IF(PERIOD=2,M,IF(PERIOD=3,M,IF(PERIOD=4,M,IF(PERIOD=5,M,IF(PERIOD=6,Q,IF(PERIOD=7,Q,IF(PERIOD=8,Q,0))))))));
AVG:=(HIGH+LOW+CLOSE)/3;
CCI:=(AVG-MA(AVG,MM))/(0.015*AVEDEV(AVG,MM));
DIF:CCI-REF(CCI,1),LINETHICK0,COLOR00FF00;
前差值:ABS(REF(CCI,1)-REF(CCI,2)),NODRAW;
差值20:IF(DIF>15 AND DIF0,-ANGLE_EMA34V,ANGLE_EMA34V);
LSMA25:=FORCAST(CLOSE,25);
X1_LSMA25:=0;
X2_LSMA25:=1;
Y1_LSMA25:=0;
Y2_LSMA25:=(REF(LSMA25,1)-LSMA25)/AVG*RANGEV;
C_LSMA25:=SQRT((X2_LSMA25-X1_LSMA25)*(X2_LSMA25-X1_LSMA25)+(Y2_LSMA25-Y1_LSMA25)*(Y2_LSMA25-Y1_LSMA25));
ANGLE_LSMA25V:=ROUND(ABS(180*ACOS((X2_LSMA25-X1_LSMA25)/C_LSMA25)/PI));
ANGLE_LSMA25:=IF(Y2_LSMA25>0,-ANGLE_LSMA25V,ANGLE_LSMA25V);
ARRAY:=CCI;
HIGHBARS:=BARSLAST(NOT(ARRAY>0));
LOWBARS:=BARSLAST(NOT(ARRAY=6 AND SUM(ARRAY>100,5)>0);
DNCONDITION:=BARSLAST(LOWBARS>=6 AND SUM(ARRAY0);
UPTREND:=ARRAY>0 AND UPCONDITIONDNCONDITION;
TRTREND:=HIGHBARS>=5 AND NOT(UPTREND) OR LOWBARS>=5 AND NOT(DNTREND);
STICKLINE(UPTREND,0,CCI,1,0),COLORFF0000;
STICKLINE(DNTREND,0,CCI,1,0),COLOR0000FF;
STICKLINE(TRTREND,0,CCI,1,0),COLOR00FFFF;
STICKLINE(NOT(UPTREND OR DNTREND OR TRTREND),0,CCI,1,0),COLOR808080;
WCCI:CCI,LINETHICK2,COLORBLACK;
TCCI:(AVG-MA(AVG,N))/(0.015*AVEDEV(AVG,N)),COLOR7A56B7,LINETHICK1;
STICKLINE(ANGLE_EMA34>=5,-301,-321,2,0),COLORD0E040;
STICKLINE(ANGLE_EMA34=3.57,-301,-321,2,0),COLOR006400;
STICKLINE(ANGLE_EMA34=2.14,-301,-321,2,0),COLOR98FB98;
STICKLINE(ANGLE_EMA34=0.71,-301,-321,2,0),COLOR00FF00;
STICKLINE(ANGLE_EMA34-0.71,-301,-321,2,0),COLOR00FFFF;
STICKLINE(ANGLE_EMA34-2.14,-301,-321,2,0),COLORE0FFFF;
STICKLINE(ANGLE_EMA34-3.57,-301,-321,2,0),COLOR00A5FF;
STICKLINE(ANGLE_EMA34-5,-301,-321,2,0),COLOR0000FF;
STICKLINE(ANGLE_EMA34=15 AND ABS(ANGLE_EMA34+ANGLE_LSMA25)>=50,IF(ANGLE_LSMA25>0,2,-2),IF(ABS(ANGLE_EMA34)>=0 AND (ANGLE_EMA34>=0 AND ANGLE_LSMA25>=0 OR ANGLE_EMA34=5,IF(ANGLE_LSMA25>0,1,-1),0));
STICKLINE(ABS(SW)=2,301,321,2,0),COLOR00FF00;
STICKLINE(ABS(SW)=1,301,321,2,0),COLOR00FFFF;
STICKLINE(ABS(SW)=0,301,321,2,0),COLOR0000FF;
IF(CLOSE>LSMA25,0,DRAWNULL),LINETHICK3,COLOR00FF00;
IF(CLOSE=200,CCI,12);
STICKLINE(C,200,200,1.5,0),COLORFFFF00;
STICKLINE(C,-200,-200,1.5,0),COLORFFFF00;
STICKLINE(C,100,100,1.5,0),COLORFFFF00;
STICKLINE(C,-100,-100,1.5,0),COLORFFFF00;

200756csatknn7swsjnaz7.gif

200756csatknn7swsjnaz7.gif

分享至:
| 0 人收藏
回复

举报 使用道具

3 个评论

北上资金   发表于 2019-7-15 08:38:25  | 显示全部楼层
还好,还有几楼
回复

举报 使用道具

股虾虾   发表于 2019-7-16 12:56:48  | 显示全部楼层
学习了。多谢楼主~
回复

举报 使用道具

炒股猛于虎   发表于 2019-7-28 08:38:14  | 显示全部楼层
我只是路过,不发表意见
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表