华星网

通达信公式 预测买卖价位主图指标

[复制链接]
5745 0

华星指标公式提示您观看的是:通达信公式 预测买卖价位主图指标
预测+买点+资金净流入量主图:
N:=27;PP:=0.03;
AAA2:=SUM(IF( CLOSE>REF(CLOSE,1),VOL*C,0),0);
AAA3:=SUM(IF( CLOSE1;
PMB:=REF(PMA,1)REF(密码,1) AND 二日比>1,COLORRED,NODRAW;
MA5:MA(C,5);MA10:MA(C,10);MA30:MA(C,30);
DRAWNUMBER(选股=1 ,L,密码),COLORYELLOW;
DRAWICON(选股,L*0.975,1);
{预测当天最低价公式}
A1:=REF(O,1);
A2:=ABS((REF(C,1)-A1)/A1);
A3:=ABS((REF(H,1)-A1)/A1);
A4:=ABS((REF(L,1)-A1)/A1);
B1:=ABS((A2+A3+A4)/3);
B2:=O*B1;
预测低一:=O-B2;
预测高一:=O+B2;
今日保护价:(REF(C,2)+REF(C,1)+O)/3 ,COLOR4080FF,NODRAW;
开盘价1:=OPEN;
开盘价2:=REF(OPEN,1);
最高价1:=HIGH;
最高价2:=REF(HIGH,1);
最低价1:=LOW;
最低价2:=REF(LOW,1);
收盘价1:=CLOSE;
收盘价2:=REF(CLOSE,1);
AA:=最高价2;
BB:=最低价2;
CC:=开盘价2;
DD:=收盘价2;
EE:=(AA+BB+CC+2*DD)/5;
AAA:=EE+(AA-BB);
BBB:=2*EE-BB;
CCC:=2*EE-AA;
DDD:=EE-(AA-BB);
上升突破价:=AAA;
上升阻力价:=BBB;
下跌支撑价:=CCC;
下跌反转价:=DDD;
EEE:=(EE+上升突破价+上升阻力价+下跌支撑价+下跌反转价)/5;
心理价:=EEE;
FFF:=(EEE+开盘价1)/2;
GGG:=(预测低一+FFF)/2;
预测低二:=GGG;
{预测今日最高价公式}
预测高二:=MA(REF(HIGH,1)/REF(CLOSE,2),N)*REF(CLOSE,1);
DRAWTEXT_FIX(1,0.04,0.15,0,'预测低一:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.10,0.15,0,CONST(预测低一)),COLORYELLOW;
DRAWTEXT_FIX(1,0.15,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.04,0.20,0,'预测高一:'),COLORFFFFFF;
DRAWNUMBER_FIX(1,0.10,0.20,0,CONST(预测高一)),COLORFFFFFF;
DRAWTEXT_FIX(1,0.15,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.15,0,'预测低二:'),COLORYELLOW;
DRAWNUMBER_FIX(1,0.24,0.15,0,CONST(预测低二)),COLORYELLOW;
DRAWTEXT_FIX(1,0.29,0.15,0,'元'),COLORYELLOW,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.20,0,'预测高二:'),COLORFFFFFF;
DRAWNUMBER_FIX(1,0.24,0.20,0,CONST(预测高二)),COLORFFFFFF;
DRAWTEXT_FIX(1,0.29,0.20,0,'元'),COLORFFFFFF,LINETHICK1;
买回价:=预测低二*1.015;
卖出价:=买回价*(1+PP);
DRAWTEXT_FIX(1,0.04,0.10,0,'卖出价:'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.10,0.10,0,CONST(卖出价)),COLOR8080FF;
DRAWTEXT_FIX(1,0.15,0.10,0,'元'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.18,0.10,0,'买回价:'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.24,0.10,0,CONST(买回价)),COLOR8080FF;
DRAWTEXT_FIX(1,0.29,0.10,0,'元'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.01,0.02,0,'★ =============================== ★'),COLORRED;
DRAWTEXT_FIX(1,0.12,0.05,0,'T+0 操 作'),COLORFFFFFF;
DRAWTEXT_FIX(1,0.01,0.08,0,'操 '),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.12,0,'盘 '),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.16,0,'铁'),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.20,0,'律'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.08,0,'坚 '),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.12,0,'决 '),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.16,0,'执'),COLOR0000FF;
DRAWTEXT_FIX(1,0.32,0.20,0,'行'),COLOR0000FF;
DRAWTEXT_FIX(1,0.01,0.24,0,'★ =============================== ★'),COLORRED;
总额:=AMOUNT;
买:=IF(O=C AND (C-REF(C,1))/REF(C,1)*100>9.8,AMOUNT,AMOUNT/((H-L)*2-ABS(O-C))*(C-L));
买%:=买/AMOUNT*100;
流入:=AMOUNT*买%/10000000000;
流出:=AMOUNT/100000000-流入;
净流:=(流入-流出);
总额3:=SUM(AMOUNT,3);
流入3:=SUM(流入,3);
流出3:=SUM(流出,3);
净流3:=SUM(流入-流出,3);
总额5:=SUM(AMOUNT,5);
流入5:=SUM(流入,5);
流出5:=SUM(流出,5);
净流5:=SUM(流入-流出,5);
总额10:=SUM(AMOUNT,10);
流入10:=SUM(流入,10);
流出10:=SUM(流出,10);
净流10:=SUM(流入-流出,10);
画:=CONST(FINDHIGH(总额10,0,190,1));
DRAWTEXT_FIX(1,0.71,0.07,0,'净流(亿):'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.78,0.05,0,'1日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.83,0.05,0,'3日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.88,0.05,0,'5日'),COLOR8080FF,LINETHICK1;
DRAWTEXT_FIX(1,0.93,0.05,0,'10日'),COLOR8080FF,LINETHICK1;
DRAWNUMBER_FIX(1,0.78,0.10,0,CONST((净流))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.83,0.10,0,CONST((净流3))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.88,0.10,0,CONST((净流5))),COLORYELLOW;
DRAWNUMBER_FIX(1,0.93,0.10,0,CONST((净流10))),COLORYELLOW;
上18H:WMA(SMA(HHV(HIGH,18),9/2,1),3);
下18L:WMA(SMA(LLV(LOW,18),9/2,1),3);
通道:(上18H+下18L)/2;
DRAWBAND(上18H,RGB(68,0,1),通道,RGB(68,0,1));
DRAWBAND(通道,RGB(3,43,63),下18L,RGB(3,43,63));
WMA(SMA(HHV(HIGH,18),9/2,1),3),COLOR0080FF,DOTLINE;
WMA(SMA(LLV(LOW,18),9/2,1),3),COLOR0080FF,DOTLINE;
(上18H+下18L)/2,COLORFFFFFF;
STICKLINE(C>=O,C,O,3.4,0),COLOR0000AA;
STICKLINE(C>=O,C,O,3.0,0),COLOR0000BB ;
STICKLINE(C>=O,C,O,2.4,0),COLOR0000CC;
STICKLINE(C>=O,C,O,2.0,0),COLOR0000DD ;
STICKLINE(C>=O,C,O,1.6,0),COLOR0000EE;
STICKLINE(C>=O,C,O,1.2,0),COLOR0000FF;
STICKLINE(C>=O,C,O,0.6,0),COLOR0000FF;
STICKLINE(C>=O,H,L,0,0),COLORRED;
STICKLINE(C=2099 AND MONTH>2,0,1);
VAR4:=LLV(LOW,5); VAR5:=HHV(HIGH,4);
散户:=EMA((VAR2-VAR4)/(VAR5-VAR4)*100,4)*VAR3;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3;
DRAWICON(CROSS(散户,庄家) AND 散户70,H+0.05,2);
VAR9:=CLOSE-REF(CLOSE,5);
VARA:=EMA(EMA(VAR9,5),5)/EMA(EMA(ABS(VAR9),5),5);
VARC:=EMA(EMA(VAR9,20),20)/EMA(EMA(ABS(VAR9),20),20);
卖出:=IF(VARA>0 AND CROSS(VARC,VARA),90,100);
DRAWICON(卖出20 AND FILTER(VC=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))),DRAWNULL)DOTLINE,COLOR00FFFF{,LINETHICK2};
看空:IF(A1X0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))),DRAWNULL)DOTLINE,COLORCYAN,{LINETHICK2};
STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
STICKLINE(CROSS(A1X,0),C,O,3,0 ),COLOR0000CC;
STICKLINE(CROSS(A1X,0),C,O,1,0 ),COLOR0033FF;
STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
N1:=10;
T1:=CONST(HHVBARS(V,10)),COLOR0000FF,LINETHICK1;
量能平台:IF(CURRBARSCOUNT=5;
FT:=BARSLAST(HV);
量能平台1:=IF(HV,C,REF(C,FT));
DRAWTEXT(量能平台1>REF(量能平台1,1)AND CREF(C,1),L,'*缩量涨'),COLORYELLOW;
DRAWTEXT(量能平台1>REF(量能平台1,1) AND C>REF(C,1) AND C>MA(C,13) AND C=HHV(C,20) AND C/REF(C,1)>1.05,L,'*突破量'),COLORFFFFFF;
{逃顶}
LC:=REF(CLOSE,1);
RSI5:=SMA(MAX(CLOSE-LC,0),5,1)/SMA(ABS(CLOSE-LC),5,1)*100;
逃命:=CROSS(80,RSI5);
DRAWICON(逃命,H*1.005,15);
TJ1:=REF("CCI.CCI",1)>90 AND "CCI.CCI"90 AND "KDJ.J"(9,3,3)70 AND "RSI.RSI1"REF("CCI.CCI",1);
TJ6:=REF("KDJ.J"(9,3,3),1)REF( "KDJ.J"(9,3,3),1);
TJ7:=REF("RSI.RSI1",1)REF("RSI.RSI1",1);
TJ8:=COUNT(TJ5,5) AND COUNT(TJ6,5) AND COUNT(TJ7,5);
大底:=CROSS(TJ8,0.5);
DRAWICON(大底,L*0.991,9);
中:(MA(C,3)+MA(C,6)+MA(C,12)+MA(C,24))/4,COLORFF951F,DOTLINE,LINETHICK2;
YJ:=中;
IF(YJ>REF(YJ,1),YJ,DRAWNULL),COLORRED,DOTLINE,LINETHICK2;
DRAWNUMBER(ISLASTBAR,HHV(C,5)*0.95*1.015,HHV(C,5)*0.95),COLORWHITE;
STICKLINE(ISLASTBAR,HHV(C,5)*0.95-0.01,HHV(C,5)*0.95,50,0),COLORWHITE;
DRAWTEXT(ISLASTBAR,HHV(C,5)*0.95,'止损价位'),COLORWHITE;
DRAWTEXT_FIX(CURRBARSCOUNT=1,0,0.897,0,'注意观察当日K线上面、下面的∧箭头(红K出现∧逢低考虑买入)。'),COLOR00BFBF;
DRAWTEXT_FIX(ISLASTBAR,0.35,0.25,0,'选股公式“震荡选股”配合买入')COLORYELLOW;

134812sxztxta5typtfhqd.png

134812sxztxta5typtfhqd.png

分享至:
| 0 人收藏
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表