华星网

公式 量学精装修主图指标

[复制链接]
6727 0

华星指标公式提示您观看的是:公式 量学精装修主图指标
量学主图精装修
实体上三分之一:(MAX(O,C)-MIN(O,C))*2/3+MIN(O,C),COLORGREEN,NODRAW;
实体下三分之一:(MAX(O,C)-MIN(O,C))/3+MIN(O,C),NODRAW;
实体二分之一:(O+C)/2,NODRAW;
整体上三分之一:(MAX(H,L)-MIN(H,L))*2/3+MIN(H,L),NODRAW;
整体下三分之一:(MAX(H,L)-MIN(H,L))/3+MIN(H,L),COLORYELLOW,NODRAW;
整体二分之一:(H+L)/2,COLORLIMAGENTA,NODRAW;
STICKLINE(OC,实体上三分之一,实体下三分之一,2,0),COLOR824173;
STICKLINE(OC,实体二分之一,实体二分之一,2,0),COLORGREEN;
最高:=HHV(MAX(O,C),N日最高);
最低:=LLV(MIN(O,C),N日最低);
上涨:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(L=最低)+1)),COLOR0000FF,NODRAW;
↑空间%:(C/REF(L,上涨)-1)*100,COLOR00FFFF,NODRAW;
最高%:(最高/REF(L,上涨)-1)*100,COLORFF00FF,NODRAW;
下跌:BARSSINCE(BACKSET(ISLASTBAR,BARSLAST(H=最高)+1)),COLOR00FF00,NODRAW;
↓空间%:(C/REF(H,下跌)-1)*100,COLOR888899,NODRAW;
最低%:(最低/REF(H,下跌)-1)*100,COLORFF0000,NODRAW;
天线:REFDATE(REF(H,下跌),DATE),POINTDOT,LINETHICK3,COLORYELLOW;
地线:REFDATE(REF(L,上涨),DATE),POINTDOT,LINETHICK3,COLORYELLOW;
中线:REFDATE((天线-地线)*0.5+地线,DATE),POINTDOT,LINETHICK3,COLORYELLOW;
STICKLINE(上涨=0,天线,地线,0,-1),COLORYELLOW;
STICKLINE(下跌=0,天线,地线,0,-1),COLORYELLOW;
DRAWTEXT(ISLASTBAR,天线,VAR2STR(天线,2)),COLORYELLOW;
DRAWTEXT(ISLASTBAR,中线,VAR2STR(中线,2)),COLORYELLOW;
DRAWTEXT(ISLASTBAR,地线,VAR2STR(地线,2)),COLORYELLOW;
{2}
高:=天线;
低:=地线;
H2:=高-(高-低)*0.333;
H3:=高-(高-低)*0.5;
H4:=高-(高-低)*0.666;
DRAWTEXT(上涨=0,天线,'-最高'),COLOR0000FF;
DRAWTEXT(上涨=0,低,'-最低'),COLORRED;
DRAWTEXT(下跌=0,高,'-高'),COLORGREEN;
DRAWTEXT(下跌=0,地线,'-低'),COLOR00FF00;
DRAWTEXT(下跌=0,H2,'-0.666'),COLORGRAY;
DRAWTEXT(下跌=0,H3,'-中'),COLORYELLOW;
DRAWTEXT(下跌=0,H4,'-0.333'),COLORLIRED;
DRAWTEXT(上涨=0,H2,'-上三一位'),COLORGRAY;
DRAWTEXT(上涨=0,H3,'-中'),COLORYELLOW;
DRAWTEXT(上涨=0,H4,'-下三一位'),COLORLIRED;
周期:CURRBARSCOUNT,NODRAW,COLORGREEN;
X_1:=REFX(HHV(MAX(OPEN,CLOSE),周期以内),周期-1);
X_2:=REFX(LLV(LOW,周期以内),周期-1);
X_3:=CLOSE/REF(CLOSE,1)CLOSE AND DATEX_6)),周期-1);
X_8:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_7)),周期-1);
X_9:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_8)),周期-1);
X_10:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_9)),周期-1);
X_11:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_10)),周期-1);
X_12:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_11)),周期-1);
X_13:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_12)),周期-1);
X_14:=REFX(REF(OPEN,BARSLAST(X_3 AND OPENX_13)),周期-1);
X_15:=REFX(BARSLAST(X_3 AND OPENX_6),周期-1)+1;
X_17:=REFX(BARSLAST(X_3 AND OPENX_7),周期-1)+1;
X_18:=REFX(BARSLAST(X_3 AND OPENX_8),周期-1)+1;
X_19:=REFX(BARSLAST(X_3 AND OPENX_9),周期-1)+1;
X_20:=REFX(BARSLAST(X_3 AND OPENX_10),周期-1)+1;
X_21:=REFX(BARSLAST(X_3 AND OPENX_11),周期-1)+1;
X_22:=REFX(BARSLAST(X_3 AND OPENX_12),周期-1)+1;
X_23:=REFX(BARSLAST(X_3 AND OPENX_13),周期-1)+1;
X_24:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_6,X_15-周期)=0);
X_25:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_7,X_16-周期)=0);
X_26:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_8,X_17-周期)=0);
X_27:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_9,X_18-周期)=0);
X_28:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_10,X_19-周期)=0);
X_29:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_11,X_20-周期)=0);
X_30:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_12,X_21-周期)=0);
X_31:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_13,X_22-周期)=0);
X_32:=IF(允许穿越=1,1,COUNT(MAX(OPEN,CLOSE)>X_14,X_23-周期)=0);
STICKLINE(周期REF(C,1)*1.090 AND CREF(C,1)*0.898;
STICKLINE(ZT,C,O,4,0),COLORYELLOW;
STICKLINE(DT,C,O,2,0),COLORBLUE;
{DRAWTEXT(ZT,L-0.1,'涨停'),COLORRED;
DRAWTEXT(DT,H+0.3,'跌停'),COLORGREEN;}
DIF:=EMA(DCLOSE,12)-EMA(DCLOSE,26);
DEA:=EMA(DIF,9);
AAA0:=(DIF-DEA)*2*60;
起爆:=CROSS(AAA0-REF(AAA0,1),15),COLORRED,LINETHICK2;
DRAWTEXT(起爆,L*0.99,'↖暴张'),COLORYELLOW,LINETHICK2;
STICKLINE(起爆,OPEN,CLOSE,0.5,0),COLORRED;
{现价画直线}
现价:DRAWLINE(CURRBARSCOUNT=TOTALBARSCOUNT,CONST(C),CURRBARSCOUNT=1,C,3),DOTLINE,COLORLIGRAY;
DRAWTEXT_FIX(1,0,0.1,0,'【所属行业】:'),COLORYELLOW;
Z1:=STRCAT(HYBLOCK,' ');
Z2:=STRCAT(Z1,DYBLOCK);
Z3:=STRCAT(Z2,' ');
DRAWTEXT_FIX(1,0.07,0.1,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;
DIR2:=ABS(CLOSE-REF(CLOSE,30));
VIR2:=SUM(ABS(CLOSE-REF(CLOSE,1)),30);
ER2:=DIR2/VIR2;
CS2:=ER2*(0.8-2/24)+2/24;
CQ2:=CS2*CS2;
M熊:EMA(DMA(CLOSE,CQ2),2),COLORGREEN,LINETHICK1;
牛熊:=M熊;{好股票网 https://www.hc1122.com 整理}
M震:IF(M熊/REF(M熊,1)>0.997,M熊,DRAWNULL),COLORCYAN,LINETHICK1;
M牛:IF(M熊/REF(M熊,1)>1.001,M熊,DRAWNULL),COLORLIRED,LINETHICK1;
HH:=(20*H+19*REF(H,1)+18*REF(H,2)+17*REF(H,3)+16*REF(H,4)+15*REF(H,5)+14*REF(H,6)
+13*REF(H,7)+12*REF(H,8)+11*REF(H,9)+10*REF(H,10)+9*REF(H,11)+8*REF(H,12)
+7*REF(H,13)+6*REF(H,14)+5*REF(H,15)+4*REF(H,16)+3*REF(H,17)+2*REF(H,18)+
REF(H,20))/210,COLORBLUE,LINETHICK1;
LL:=(20*L+19*REF(L,1)+18*REF(L,2)+17*REF(L,3)+16*REF(L,4)+15*REF(L,5)+14*REF(L,6)
+13*REF(L,7)+12*REF(L,8)+11*REF(L,9)+10*REF(L,10)+9*REF(L,11)+8*REF(L,12)
+7*REF(L,13)+6*REF(L,14)+5*REF(L,15)+4*REF(L,16)+3*REF(L,17)+2*REF(L,18)+
REF(L,20))/210,COLORBLUE,LINETHICK1;
D90H:=EMA(HH,90),COLORRED,LINETHICK1;
D90L:=EMA(LL,90),COLORRED,LINETHICK1;
G0:=(XMA(XMA(H,25),25)-XMA(XMA(L,25),25))+XMA(XMA(H,25),25);
D0:=XMA(XMA(L,25),25)-(XMA(XMA(H,25),25)-XMA(XMA(L,25),25));
{GO0:=(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3+XMA(XMA(H,60),60);
DO0:=XMA(XMA(L,60),60)-(XMA(XMA(H,60),60)-XMA(XMA(L,60),60))*3;}
{STICKLINE(CURRBARSCOUNT=1,G0,G0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,D0,D0,100,5),COLORYELLOW;
STICKLINE(CURRBARSCOUNT=1,GO0,GO0,100,5),COLORMAGENTA;
STICKLINE(CURRBARSCOUNT=1,DO0,DO0,100,5),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,G0,'卖'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,D0,'买'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,GO0,'顶'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,DO0,'底'),COLORMAGENTA;}
DTD:=(D0+G0)/2>=(D90H+D90L)/2;
YM:=EMA(SLOPE((CLOSE+HIGH+LOW)/3,24)*20+(CLOSE+HIGH+LOW)/3,48),COLORRED,LINETHICK1;
YM1:=EMA(YM,5),COLORGREEN,LINETHICK1;
STICKLINE(LYM1,L,D0,1.5,0),COLORWHITE;
VAR01:=(C+H+O+L)/4;
卖出:=XMA(VAR01,N)*(1+P1/1000),COLORGREEN,POINTDOT,LINETHICK3;
买入:=XMA(VAR01,M)*(1-P2/1000),COLORMAGENTA,POINTDOT,LINETHICK3;
{DRAWBAND(卖出,RGB(0,80,60),买入,RGB(0,0,0));}
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
幅度:100*(卖出-买入)/买入,NODRAW,COLORFF00FF;
MA1:=MA(VAR01,3);
STICKLINE(卖出>LOW AND 卖出MIN(C,O) AND 卖出LOW AND 卖出LOW AND 买入MIN(C,O) AND 买入LOW AND 买入HIGH,OPEN,CLOSE,2,0),COLORMAGENTA;
STICKLINE(买入>HIGH,HIGH,LOW,0,0),COLORMAGENTA;
{DRAWTEXT(CROSS(C,买入) OR (L卖出),HIGH*1.02,'S'),COLORGREEN;};

134820l41jb8myi8y056p1.png

134820l41jb8myi8y056p1.png

分享至:
| 0 人收藏
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表