华星网

通达信公式 黄金三角公式主图指标

[复制链接]
6290 0

华星指标公式提示您观看的是:通达信公式 黄金三角公式主图指标
该指标公式买卖指示比较多,但其中用到了未来函数,仅作为买卖的参考依据!
MA5:MA(C,5);
MA6:=MA(C,6);
MA10:MA(C,10);
MA20:MA(C,20);
A2:=REF(MA20,1);
J1:=(MA20-A2)/A2*100;
MJ1:=MA(J1,3);
MA30:MA(C,30);
MA60:MA(C,60);
MA120:MA(C,120);
乖离2:=(MA20-MA30)/MA30*100;
VAR1:=IF(BETWEEN(乖离2,-2,5),2,0);
MAX1:=MAX(MA20,MA30);
MAX2:=MAX(MAX1,MA60);
MIN2:=MIN(1,MA60);
K1:=(MAX2/MIN2-1)*100;
VAR2:=IF(K1REF(MA10,1) AND COUNT(MA30>REF(MA30,1),3)=3 AND MA30>MA60 AND COUNT(CROSS(MA5,MA30),3) AND J1>MJ1 AND MA(V,5)>MA(V,60)
AND MA(V,60)>REF(MA(V,60),1),5),MA60*0.99,'短线暴张'),COLORRED;
DRAWICON(短线暴张,L*0.85,25);
DRAWTEXT(CROSS("KDJ.K"(5,2,3),"KDJ.D"(5,2,3)) AND "KDJ.D"(5,2,3)MJ1 AND MA60>REF(MA60,1) AND COUNT(J1=1 ,L*0.995,'←买入'),COLORYELLOW;
DRAWTEXT(CROSS("KDJ.D"(5,2,3),"KDJ.K"(5,2,3)) AND "KDJ.D"(5,2,3)>65 AND J11,3)>=1,H*1.005,'←卖出'),COLORGREEN;
DRAWTEXT(CROSS("KDJ.D"(18,9,6),"KDJ.K"(18,9,6)) AND "KDJ.D"(18,9,6)>60 AND "KDJ.J"(45,15,15)>90,H*1.03,'←顶'),COLORRED;
DRAWTEXT(CROSS(MA5,MA6) AND "KDJ.K"(5,3,3)>=50 AND "KDJ.J"(5,3,3)= 1.04));
XL2:=(((CLOSE - EMA(CLOSE,21)) / EMA(CLOSE,21)) * 100);
XL3:=CROSS(XL2,(0 - 20));
DRAWTEXT(FILTER(((XL1 > 0) AND LOW),5),(LOW - 0.4),'●买点');
DRAWTEXT((XL3 > 0),(LOW - 0.2),'●绝对底部');
X6:=REF(CLOSE,1);
X7:=((SMA(MAX((CLOSE - X6),0),7,1) / SMA(ABS((CLOSE - X6)),7,1)) * 100);
X8:=CROSS(79,X7);
X9:=FILTER(X8,4);
DRAWTEXT(X9,(HIGH * 1.02),'●出货'),COLOR9000F5;
STICKLINE(C>1.098*REF(C,1),C,O,0,0),COLORYELLOW;
AAA:=CONST(HHV(H,90));
R1:=MA(CLOSE,1);
R2:=MA(CLOSE,3);
R3:=(MA(R2,1)*1);
R4:=(MA(R2,3)*1);
LC:=REF(CLOSE,1);
RSI:=((SMA(MAX((CLOSE - LC),0),3,1) / SMA(ABS((CLOSE - LC)),3,1)) * 100);
FF:=EMA(CLOSE,3);
MA15:=EMA(CLOSE,21);
VARE:=MA(100*(CLOSE-LLV(CLOSE,34))/(HHV(HIGH,34)-LLV(LOW,34)),5)-20;
VAR12:=(HIGH+LOW+CLOSE)/3;
VAR13:=(VAR12-MA(VAR12,14))/(0.015*AVEDEV(VAR12,14));
VAR14:=(VAR12-MA(VAR12,70))/(0.015*AVEDEV(VAR12,70));
VAR15:=IF(VAR13>=150 AND VAR13=150 AND VAR14-200 AND VAR14-200,-10,VAR15);
VAR17:=(CLOSE-MA(CLOSE,13))/MA(CLOSE,13)*100;
VAR18:=100-ABS(VAR17);
VAR19:=IF(VAR180,VARE,0);
VAR1B:=IF(VAR14>=200 AND VAR13>=150,15,IF(VAR1448 AND VAR1B>60 AND VAR191.2;
DD1:=L MA(CLOSE,5));
A76:=(MA(CLOSE,5) > MA(CLOSE,10));
A77:=(CLOSE > MA(CLOSE,10));
A78:=(MA(CLOSE,5) > MA(CLOSE,20));
A79:=(CLOSE > MA(CLOSE,20));
A710:=REF(A74,1);
A711:=(A74 > A710);
AVX:=(((((IF(A75,10,(0 - 10)) + IF(A76,10,(0 - 10))) + IF(A77,10,(0 - 10)))
+ IF(A78,10,(0 - 10))) + IF(A79,10,(0 - 10))) + IF(A711,10,(0 - 10)));
DSLX:=(CLOSE / INDEXC);
DSLX1:=MA(DSLX,5);
DSLX2:=MA(DSLX,10);
V1:=MA(VOL,5);
V2:=MA(VOL,10);
T1:=CONST(IF(C= V2)) AND (DSLX >= DSLX1)),1,0));
T2:=CONST(IF(C= DSLX1)),1,0));
T3:=CONST(IF(C V2)) AND (DSLX = V2)) AND (DSLX >= DSLX1)),1,0));
T6:=CONST(IF(C= DSLX1)),1,0));
T7:=CONST(IF(C= V2)) AND (DSLX = 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX >= DSLX1)),1,0));
T10:=CONST(IF(C= 1) AND (REF(AVX,1) > 0)) AND (V1 = DSLX1)),1,0));
T11:=CONST(IF(C= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)) AND (DSLX = 1) AND (REF(AVX,1) > 0)) AND (V1 = V2)) AND (DSLX >= DSLX1)),1,0));
T14:=CONST(IF( C= DSLX1)),1,0));
T15:=CONST(IF(C= V2)) AND (DSLX 200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T18:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 >= V2)),1,0));
T19:=CONST(IF(C>200 AND (CROSS(AVX,1) AND (V1 200 AND (CROSS(1,AVX) AND (V1 >= V2)),1,0));
T21:=CONST(IF(C>200 AND (CROSS(1,AVX) AND (V1 200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 >= V2)),1,0));
T23:=CONST(IF(C>200 AND (((AVX >= 1) AND (REF(AVX,1) > 0)) AND (V1 200 AND (((AVX = V2)),1,0));
T25:=CONST(IF(C>200 AND (((AVX =2099 AND MONTH>2,0,1);
VAR4S:=LLV(LOW,5); VAR5S:=HHV(HIGH,4);
散户:=EMA((VAR2S-VAR4S)/(VAR5S-VAR4S)*100,4)*VAR3S;
庄家:=EMA(0.667*REF(散户,1)+0.333*散户,2)*VAR3S;
DRAWTEXT(CROSS(散户,庄家) AND 散户SMA2,(LOW * 0.97),'←⊙鱼儿买'),COLORRED;
新SAR100:=NEWSAR(1,100),COLORLIMAGENTA;
新SAR10:=NEWSAR(1,10);
新SAR5:=NEWSAR(1,5);
新SAR1:=NEWSAR(1,1);
现价:=C;
前20内高:=HHV(C,20);
昨前高:CONST(REF(前20内高,2)),COLORYELLOW;
XX:=DRAWLINE(CURRBARSCOUNT=5,昨前高*0.98,CURRBARSCOUNT=1,昨前高,0);
DRAWBAND(昨前高,RGB(255,255,0),XX,RGB(0,0,0));
XX1:=DRAWLINE(CURRBARSCOUNT=9,昨前高,CURRBARSCOUNT=5,昨前高*0.98,0);
DRAWBAND(昨前高,RGB(255,255,0),XX1,RGB(0,0,0));
新SAR101:NEWSAR(1,100),COLORLIMAGENTA;
反转:=新SAR101新SAR101; DRAWICON(反转,L*0.85,23);
M120:MA(C,120);
M240:MA(C,240);
MSAR24:MA(新SAR100,24),COLORYELLOW;

134815f2jruu78ttmmp7nx.jpg

134815f2jruu78ttmmp7nx.jpg

分享至:
| 0 人收藏
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表