华星网

通达信公式 周复利目标副图指标

[复制链接]
6471 0

华星指标公式提示您观看的是:通达信公式 周复利目标副图指标
有些股民经常会算,如果每天盈利1%、每周盈利多少、一年就能翻多少倍,其实这样的目标不现实,如果创业板调整时,个股每天都下跌,扔强迫自己每天、每周盈利多少,很难实现,很难达成目标,也不科学。
而我们把目标设立成“跑赢创业板”的话,即便每周“跑赢1%”,每年52周,年复利达1.68倍,1年后哪怕创业板还在2100点,能跑赢创业板68%,就相当于盈利了68%!这种目标更科学,最重要的是它可实现,他是我们能达成的目标,所以这款公式就诞生了。
我们只需要每周五收盘后,在公式内填写“总资金”,记录每周的总资金,公式就可以计算出各个数值、各项功能都可以很方便的让我们直观的看到我们以往和现在的操作,非常实用。

134821ic505rlr05bv5ryy.png

134821ic505rlr05bv5ryy.png

134821bg4rg4t0riq6gqdn.png

134821bg4rg4t0riq6gqdn.png

【使用方法介绍】
一、第一次使用,需要设置5个参数,也就是截图内“红色框框这里”(理解能力强的,看截图内的描述就会自己修改了,下面我扔详细的讲下)
参数1,给自己设置个目标,你能每周跑赢创业板多少、就设置多少,默认是2%(比如说,本周你资金增长5%,创业板周涨幅1%,那么本周你跑赢创业板4%,公式是这样计算的)
参数2,每周跑赢创业板第2目标,建议比第一目标少一些,默认是1.7(比第一目标少0.3)
参数3,每周跑赢创业板第3目标,建议比第一目标多一些,默认是2.3(比第一目标多0.3)
参数4,你使用这个公式开始记录自己资金时,周K线的日期(比如今天是星期日,那么创业板最后一根K线的日期是161125)
参数5,目前的总资产,填写到这里。(根据这个计算你之后每周、每年的收益和跑赢创业板的幅度)
二、之后每周,星期五收盘后,记录每周的总资金
将截图内蓝色部分 DRAWNULL 改成自己的总资金,就可以了,每周记录一次。
----------------------
补充:
一、因为是对比,资金增长率和大盘涨幅的公式,所以一定要在“4大指数的周k线”下使用,建议创业板、周K线使用。
二、推荐,开启通达信“侧边栏”版式下使用,幅图宽度更小,方便截图分享(图更小、论坛不压缩,更清晰)
三、第一次使用,建议“起始日期改成160930”或其他“周K线某根K线的日期”,然后“任意填写出10周以上的总资金”,把折线图调出来,自己研究研究。

134821ordg2nxr2xnrgzaf.png

134821ordg2nxr2xnrgzaf.png

一、红色框这里的4个数值,就是幅图中,白、黄、紫、蓝这4条线
1、第1条是以周复利1.7%计算的折线(截图目前是7周,所以是12.52%)
2、第2条是以周复利2.0%计算的折线(截图目前是7周,所以是14.87%)
3、第3条是以周复利2.3%计算的折线(截图目前是7周,所以是17.25%)
4、第4条是我“每周跑赢创业板的幅度”,也才刚刚跑赢最小的这条而已...(截图目前是7周,跑赢创业板12.67%)
二、红色框右侧的3个数值
1、白色这个数值是,我们“周资金”的涨幅
2、黄色这个数值是,大盘“周K线”的涨幅
3、蓝色这个数值是,我们跑赢创业板的涨幅
三、白色框左侧的5个数值
1、第1个数值是本周,周资金的涨幅
2、第2个数值是本周,大盘周K线的涨幅
3、第3个数值是本周,跑赢创业板的涨幅
4、第4个数值是周复利目标(第一次使用公式时设置的)
5、第5个数值是本周,资金盈亏额。
四、黄色框左侧的5个数值
同上、不同的仅仅是,计算的周期不是周,而是起始日至今天。
其他说明:
我们在什么指数周K线下使用,大盘的计算数值就计算那个指数(创业板指、中小板指、上证A股等均可使用…更推荐中小创)
指标源码:
DYMB:=2;{每周能跑赢大盘多少,就设置多少,这是第1目标,也就是 目标 这条黄色线}
AMBA:=1.7;{建议比第1目标少0.2%到0.5%,这是第2目标,也就是 MBA 这条白色线}
CMBC:=2.3;{同上,如果操作一段时间发现无法达成目标,三个目标数值可随时更改}
QSR:=160930;{起始日期}
QSZJ:=37114;{起始资金、本金}
A:=BARSLAST((DATE-1000000)=QSR);
MBA:(IF(A=0,1,REF(MULAR(AMBA/100+1,0),1+BARSLAST(BARSTATUS=1)-BARSLAST((DATE-1000000)=QSR)))-1)*100,COLORFFFFFF;
目标:(IF(A=0,1,REF(MULAR(DYMB/100+1,0),1+BARSLAST(BARSTATUS=1)-BARSLAST((DATE-1000000)=QSR)))-1)*100,COLOR00FFFF;
MBC:(IF(A=0,1,REF(MULAR(CMBC/100+1,0),1+BARSLAST(BARSTATUS=1)-BARSLAST((DATE-1000000)=QSR)))-1)*100,COLORFF00FF;
ZJ1:=IF(A=0,QSZJ,
IF(A= 1,DRAWNULL,{第一周最后一个交易日收盘时,DRAWNULL 改成自己的总资金}
IF(A= 2,DRAWNULL,{第一周最后一个交易日收盘时,DRAWNULL 改成自己的总资金}
IF(A= 3,DRAWNULL,{下面类同}
IF(A= 4,DRAWNULL,
IF(A= 5,DRAWNULL,
IF(A= 6,DRAWNULL,
IF(A= 7,DRAWNULL,
IF(A= 8,DRAWNULL,
IF(A= 9,DRAWNULL,
IF(A=10,DRAWNULL,
IF(A=11,DRAWNULL,
IF(A=12,DRAWNULL,
IF(A=13,DRAWNULL,
IF(A=14,DRAWNULL,
IF(A=15,DRAWNULL,
IF(A=16,DRAWNULL,
IF(A=17,DRAWNULL,
IF(A=18,DRAWNULL,
IF(A=19,DRAWNULL,
IF(A=20,DRAWNULL,
IF(A=21,DRAWNULL,
IF(A=22,DRAWNULL,
IF(A=23,DRAWNULL,
IF(A=24,DRAWNULL,
IF(A=25,DRAWNULL,
IF(A=26,DRAWNULL,
IF(A=27,DRAWNULL,
IF(A=28,DRAWNULL,
IF(A=29,DRAWNULL,
IF(A=30,DRAWNULL,
IF(A=31,DRAWNULL,
IF(A=32,DRAWNULL,
IF(A=33,DRAWNULL,
IF(A=34,DRAWNULL,
IF(A=35,DRAWNULL,
IF(A=36,DRAWNULL,
IF(A=37,DRAWNULL,
IF(A=38,DRAWNULL,
IF(A=39,DRAWNULL,
IF(A=40,DRAWNULL,
IF(A=41,DRAWNULL,
IF(A=42,DRAWNULL,
IF(A=43,DRAWNULL,
IF(A=44,DRAWNULL,
IF(A=45,DRAWNULL,
IF(A=46,DRAWNULL,
IF(A=47,DRAWNULL,
IF(A=48,DRAWNULL,
IF(A=49,DRAWNULL,
IF(A=50,DRAWNULL,DRAWNULL)))))))))))))))))))))))))))))))))))))))))))))))))));ZJ2:=
IF(A=51,DRAWNULL,
IF(A=52,DRAWNULL,
IF(A=53,DRAWNULL,
IF(A=54,DRAWNULL,
IF(A=55,DRAWNULL,
IF(A=56,DRAWNULL,
IF(A=57,DRAWNULL,
IF(A=58,DRAWNULL,
IF(A=59,DRAWNULL,
IF(A=60,DRAWNULL,
IF(A=61,DRAWNULL,
IF(A=62,DRAWNULL,
IF(A=63,DRAWNULL,
IF(A=64,DRAWNULL,
IF(A=65,DRAWNULL,
IF(A=66,DRAWNULL,
IF(A=67,DRAWNULL,
IF(A=68,DRAWNULL,
IF(A=69,DRAWNULL,
IF(A=70,DRAWNULL,
IF(A=71,DRAWNULL,
IF(A=72,DRAWNULL,
IF(A=73,DRAWNULL,
IF(A=74,DRAWNULL,
IF(A=75,DRAWNULL,
IF(A=76,DRAWNULL,
IF(A=77,DRAWNULL,
IF(A=78,DRAWNULL,
IF(A=79,DRAWNULL,
IF(A=80,DRAWNULL,
IF(A=81,DRAWNULL,
IF(A=82,DRAWNULL,
IF(A=83,DRAWNULL,
IF(A=84,DRAWNULL,
IF(A=85,DRAWNULL,
IF(A=86,DRAWNULL,
IF(A=87,DRAWNULL,
IF(A=88,DRAWNULL,
IF(A=89,DRAWNULL,
IF(A=90,DRAWNULL,
IF(A=91,DRAWNULL,
IF(A=92,DRAWNULL,
IF(A=93,DRAWNULL,
IF(A=94,DRAWNULL,
IF(A=95,DRAWNULL,
IF(A=96,DRAWNULL,
IF(A=97,DRAWNULL,
IF(A=98,DRAWNULL,
IF(A=99,DRAWNULL,
IF(A=100,DRAWNULL,
ZJ1))))))))))))))))))))))))))))))))))))))))))))))))));
总资产:=IF(ZJ2=DRAWNULL,REF(ZJ2,1),ZJ2),NODRAW,COLORFFFFFF;
DX1:=(总资产/REF(总资产,A)-1)*100;
DX2:=(C/REF(C,A)-1)*100;DX3:=DX1-DX2;
跑赢大盘:DX3,COLORFFFF00;
DRAWRECTREL(0,0,139,1000,RGB(25,25,25));
周盈亏:(总资产/REF(总资产,1)-1)*100,NODRAW,COLORFFFFFF;
周大盘:(C/REF(C,1)-1)*100,NODRAW,COLOR00FFFF;
周跑赢:周盈亏-周大盘,NODRAW,COLORFFFF00;XX5:=总资产-REF(总资产,1);XX7:=总资产-REF(总资产,A);{www.hc1122.com}
DRAWTEXT_FIX(ISLASTBAR AND A>0,0.115,0.83,1,VAR2STR(REF(QSZJ,A),0)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND 周跑赢0 AND XX7>=0,0.115,0.6,1,VAR2STR(XX7,0)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.5,0,'%'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND 周大盘0 AND DX1>=0,0.115,0.4,1,VAR2STR(DX1,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.6,1,'盈亏:'),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.045,0.02,0,'周盈亏'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND DX2>=0,0.115,0.45,1,VAR2STR(DX2,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.27,1,'盈亏:'),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.27,0,'元'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.40,1,'个人:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.12,1,'大盘:'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.07,1,'个人:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.17,1,'跑赢:'),COLORFFFF00;
DRAWTEXT_FIX(ISLASTBAR AND A>0,0.115,0.73,1,VAR2STR(REF(DATE-1000000,A),0)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.55,1,'目标:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.07,0,'%'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND 周盈亏0 AND 周跑赢>=0,0.115,0.17,1,VAR2STR(周跑赢,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND XX5>=0,0.115,0.27,1,VAR2STR(XX5,0)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND DX20 AND DYMB>0,0.115,0.55,1,VAR2STR(目标,2)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.027,0.68,0,'总资产收益'),COLORFF00FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.93,1,'次目标:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.4,0,'%'),COLORFFFFFF;DRAWTEXT_FIX(ISLASTBAR,0.3,0.95,0,STRCAT(STRCAT('理想论坛',' 刘小刀 '),'作品')),COLOR333333;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND 周盈亏>=0,0.115,0.07,1,VAR2STR(周盈亏,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.50,1,'跑赢:'),COLORFFFF00;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.55,0,'%'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.78,1,'距今:'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.22,1,'目标:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND DYMB>0,0.115,0.22,1,VAR2STR(DYMB,2)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND DX10 AND DX3>=0,0.115,0.5,1,VAR2STR(DX3,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.45,1,'大盘:'),COLOR00FFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND XX50 AND QSZJ>=0,0.115,0.88,1,VAR2STR(总资产,0)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0,0.115,0.78,1,VAR2STR(A,0)),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND XX70 AND 周大盘>=0,0.115,0.12,1,VAR2STR(周大盘,2)),COLOR0000FF;
DRAWTEXT_FIX(ISLASTBAR,0.065,0.73,1,'起始日:'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.22,0,'%'),COLORFFFFFF;
DRAWTEXT_FIX(ISLASTBAR AND A>0 AND DX3<0 ,0.115,0.5,1,VAR2STR(DX3,2)),COLOR00FF00;
DRAWTEXT_FIX(ISLASTBAR,0.118,0.88,0,'元'),COLORFFFFFF;

分享至:
| 0 人收藏
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表