华星网

通达信公式 与MACD红绿柱相关的【趋势线】主图指标

[复制链接]
5468 0

华星指标公式提示您观看的是:通达信公式 与MACD红绿柱相关的【趋势线】主图指标
此趋势线与其他的趋势线是完全不同的。此趋势线是:“连结MACD相邻红绿柱区间内股价高低点所画的趋势线”!
思路:
以最近两DIF大于DEA的区间(不包含当前区间)内的股票最高价为基准点,做一条趋势线。
以最近两DIF小于DEA的区间(不包含当前区间)内的股票最低价为基准点,做一条趋势线。
用法:
以最近两DIF大于DEA的区间(不包含当前区间)内的股票最高价为基准点,做一条趋势线。突破上轨道买进;
以最近两DIF小于DEA的区间(不包含当前区间)内的股票最低价为基准点,做一条趋势线。突破下轨道卖出;
注意:画线用到了未来函数,不喜欢的就不要下了。指标只用来参考,决策还的靠人脑!
源码:
{连结MACD相邻红绿柱区间内高低点画趋势线 通达信}
DIFF:=EMA(CLOSE,12)-EMA(CLOSE,26);
DEA:=EMA(DIFF,9);
N1:=BARSLAST(CROSS(DIFF,DEA))+1;{最近一次满足条件DIFF上穿DEA的K线到当前的距离}
N2:=BARSLAST(CROSS(DEA,DIFF))+1;{最近一次满足条件DIFF下穿DEA的K线到当前的距离}
{当前是DIFF>DEA的状态,连结最近两个DIFF>DEA区间(不包含当前区间)内最高点的趋势线}
A1:=BACKSET(ISLASTBAR && N1DEA的状态,连结最近两个DIFFN2,REF(REF(LLVBARS(L,N2)+1,N1),N1)+REF(N1,N1)+N1);
B3:=BACKSET(ISLASTBAR && N1>N2,REF(LLVBARS(L,N2),N1)+N1+1);
DRAWLINE(CROSS(A3,0.5),L,CROSS(B3,0.5),L,1),COLORGREEN;
{当前是DIFFDEA区间内最高点的趋势线}
A4:=BACKSET(ISLASTBAR && N1>N2,REF(REF(HHVBARS(H,N1)+1,N2),N1)+REF(N2,N1)+N1);
B4:=BACKSET(ISLASTBAR && N1>N2,REF(HHVBARS(H,N1)+1,N2)+N2);
DRAWLINE(CROSS(A4,0.5),H,CROSS(B4,0.5),H,1),COLORRED;

134821nlcazenlwnql4a3n.png

134821nlcazenlwnql4a3n.png

134821iuoc4ic4mwgu318p.png

134821iuoc4ic4mwgu318p.png

分享至:
| 0 人收藏
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表