华星网

通达信公式 最牛B的黄金分割线有整套操作流程主图指标

[复制链接]
4659 1

华星指标公式提示您观看的是:通达信公式 最牛B的黄金分割线有整套操作流程主图指标
黄金分割是一个通达信主图指标,里面有三条水平线:一个是红色的顶点线,一个是黄色的%61.8线(俗称黄金线),一个是绿色的低点线。三条线都是支撑线,也是压力线。当股价下行到接近任意一条线时,这条线就是支撑线,当股价上行到接近任意一条线时,这条线就是压力线。
当股价上穿任意一条线,且有量能配合,可以买入;当股价回调不破下面一条线,带量反弹,是上签买点;当股价上涨到接近上面的一条线时,考虑卖出。
黄金分割-通达信主图指标
原理:
1.黄金分割是一个通达信主图指标,里面有三条水平线:一个是红色的顶点线,一个是黄色的%61.8线(俗称黄金线),一个是绿色的低点线。
2.三条线都是支撑线,也是压力线。
3.当股价下行到接近任意一条线时,这条线就是支撑线,当股价上行到接近任意一条线时,这条线就是压力线。
用法:
1.当股价上穿任意一条线,且有量能配合,可以买入;
2.当股价回调不破下面一条线,带量反弹,是上签买点;
3.当股价上涨到接近上面的一条线时,考虑卖出。
{以下为参数,依次填写到参数表里}
P1(0,10000,5);
P2(0,10000,10);
P3(0,10000,20);
P4(0,10000,30);
P5(0,10000,60);
{以下为函数,全部粘贴到大框里}
MA5: MA(CLOSE,P1);
MA10: MA(CLOSE,P2);
MA20: MA(CLOSE,P3);
MA30: MA(CLOSE,P4);
MA60: MA(CLOSE,P5);
STICKLINE(C>REF(C,1)*1.095,C,O,2,0),COLORYELLOW;
JXX:=BARSLASTCOUNT(C=4)*JXX,JXX);
JXS:=BARSLASTCOUNT(C>MA20);
JXS1:=BACKSET((JXS>=4)*JXS,JXS);
KGC:=BARSLASTCOUNT(NOT(JXX1 OR JXS1));
JXL:=BARSLASTCOUNT(REF(JXX1>0,KGC));
JXH:=BARSLASTCOUNT(REF(JXS1>0,KGC));
XWZ:=FILTERX(LLV(L,JXL)=L,JXL);
SWZ:=FILTERX(HHV(H,JXH)=H,JXH);
{DRAWLINE(XWZ,L,SWZ,H,0),COLOR00FFFF};
高:=REF(H,BARSLAST(SWZ));
低:=REF(L,BARSLAST(XWZ));{这种情况应对目前在20下方}
BB:=BARSLAST(JXL=1);{上次JXL等于1距今天数}
顶点2:=REF(高,BARSLAST(JXL)),COLORYELLOW;
低点2:=REF(低,BB),COLORYELLOW;{上次等于1对应的低价}
H23:=((顶点2-低点2)*0.236+低点2);
H38:=((顶点2-低点2)*0.382+低点2);
H中:=((顶点2-低点2)*0.5+低点2);
H61:=((顶点2-低点2)*0.618+低点2);
H80:=((顶点2-低点2)*0.809+低点2);
H138:=((顶点2-低点2)*1.382+低点2);
顶点:REFDATE(顶点2,DATE),COLORRED LINETHICK1;
低点:REFDATE(低点2,DATE),COLORGREEN LINETHICK1;
%23.6:=REFDATE(H23,DATE),COLORYELLOW,DOTLINE;
%38.2:=REFDATE(H38,DATE),COLORYELLOW,DOTLINE;
%50:=REFDATE(H中,DATE),COLORYELLOW,DOTLINE;
%61.8:REFDATE(H61,DATE),COLORYELLOW,DOTLINE;
%80.9:=REFDATE(H80,DATE),COLORYELLOW,DOTLINE;
%138.2:=REFDATE(H138,DATE),COLORYELLOW,DOTLINE;
DRAWTEXT(ISLASTBAR,顶点,'顶点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%23.6,'%23.6'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,%38.2,'%38.2'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%50,'%50'),COLORRED;
DRAWTEXT(ISLASTBAR,%61.8,'%61.8'),COLORMAGENTA;
DRAWTEXT(ISLASTBAR,%80.9,'%80.9'),COLORYELLOW;
DRAWTEXT(ISLASTBAR,低点,'低点'),COLORWHITE;
DRAWTEXT(ISLASTBAR,%138.2,'%138.2'),COLORMAGENTA;

135853dsuoy82ywyy2wo84.png

135853dsuoy82ywyy2wo84.png

135853mdi0umevuomvdou3.png

135853mdi0umevuomvdou3.png

分享至:
| 0 人收藏
回复

举报 使用道具

1 个评论

2020 发表于 10-5 14:37:00  | 显示全部楼层
源码都不全
回复

举报 使用道具

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

图文热点

更多

今日关注

QQ交流群
华星网
帮助中心
站点帮助
关于我们
免责声明
版权声明
广告合作

本站所有文章、数据仅供参考,使用前务请仔细阅读法律声明,风险自负

【广告、问题】Email:admin@hc1122.com

工业和信息化部信息备案:沪ICP备13040455号-1

Copyright   ©2013-2019  华星网  All Rights Reserved

快速回复 返回顶部 返回列表